Wallet Daemon Installation

Evening all,

Really really struggling with the daemon wallet installation. Have tried to follow the instructions from the video (Although the Link shown no longer seems to be valid). Due to dead link have installed the version from the link under the video (whilst still using instructions in the video).

Anything im missing here? :(!!!

Hi @redd,

Sorry for the slow reply, we totally missed your thread here and I’m sorry.

Enjin has indeed moved the download link and it’s available here: https://docs.enjin.io/wallet-daemon/#enjinwalletdaemoninstallation

There you will find both a fresh download link and instructions on how to install. I’ve replaced the link in the course as well :slight_smile:

I would remove your previous installation and start over with the fresh files.

1 Like

Thanks @filip.

After a few days off I’ve managed to go through it all again and appears to be installed OK this time.

Now getting a fresh problem when i try and create the wallet though. As per screenshot below, getting a ton of errors when using the line “node src/main.js account new”… any thoughts? :frowning:


Is this the first time you ran this command? Because this normally happens if you already have an enjin account created and enters the wrong password to decrypt it.

You can check for any wallet by looking into %LOCALAPPDATA%\enjin-wallet-daemon\storage.json. That’s where enjin is storing the data.

Try to delete that file and start over with the account new command.

1 Like

Yep appeared i must have already created a wallet on a previous attempt as removing that file worked and now I’m progressing with the course again.

Many thanks for your help! Thanks @Filip!

Great! Good luck with the rest of the course :slight_smile:

1 Like

Hi Filip & Team!

i have an issue with the terminal installing the daemon wallet.

i was following along the documentation on the link you were giving.

/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

the screenshot shows how the terminal stops and doesnt take any other commands. Whhats up with that?

appreciate your help guys!

Screen Shot 2021-06-08 at 11.11.22 AM

@thecil can you help me out with this?

1 Like

Hey @Dexda, hope you are ok

I might need more info about your issue, i assume you are using MacOs right?

Also which step of the guide are you stuck on?

Carlos Z

hi, using macOS Catalina;
stuck on the first line to input in the terminal. see screenshot above.

Im trying to follow the course along and wasnt really able to link the wallet to an ethereum address like filip did.

After having some issues running this code in the terminal on my MAC(OS Catalina)

/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

i simply downloaded the master-enjin-wallet file provided by you guys. I then tried to set the followiing commands in the terminal like so:
cd “Enjin folder” > npm install (seemed to work at first but then apparently didn’t because once i typed

> node src/main.js account new &&
> node src/main.js link "Insert linking code" 

i got error messages.
So im left without an ethereum address linked to this enjin account. I dont really know how to fix this…

1 Like

you might want to check the installation instructions for MAC OS: https://enjin.io/docs/daemon-installation

Also please provide the error message that is showed to you

Carlos Z

hi carlos thanks i was following through the wallet installation documentation at first but it wasnt working. Anyway now i got the first installation of homebrew up and running; however, the 2nd line to install NODE.JS throws the following error message

Screen Shot 2021-06-15 at 7.19.17 PM

i was looking at “docs.brew.sh” to find a solution but havent yet. are you familiar with this?

This might be useful :nerd_face:


Carlos Z

Hello, when running node src/main.js account new it works, my problem is with linking node src/main.js link <LINK_CODE>, when I use the code in graphiql
“data”: {
“EnjinIdentities”: [
“id”: MYID,
“app”: {
“name”: “testgrt”
“linkingCode”: “MYCODE”,
“wallet”: null
I use the linking code from this query and
It throws me this error
“message”: “An unexpected error has occurred.”,
“code”: 500
When I use the code in my settings, it is linked but I think that’s not the point.
Any help would be appreciated.

I tried the same thing on Ubuntu, same result.

During setting up wallet i am stuck on error 400 please help
“message”: “Attempting to link a non-player user.”,
“code”: 400

Howdy, :sunglasses:
Were you able to get around this?

EDIT: You get around it by getting the linking code from the platform (In settings). The GraphIQL gave me the wrong linking code.

1 Like