Visual Studio code

im on a Mac and theres no command prompt in the bash drop down menu , have no idea where to go or what to do from here, tried shell command from command pallet and seem to be missing something or not typing right, im as new as you can get with this kinda thing,
this is what shows up in the terminal,
Murrays-iMac:~ murraygainford$


Hey @Beasly, hope you are well.

I guess you mean the terminal window on visual code, this link should help you to understand how it works:

Carlos Z

~ (tilde) is your home folder. Navigation works similarly in Windows and macOS, but this is something you’d have to get familiar with (e.g. googling macOS terminal commands like cd, ls). Alternatively, you can just imitate everything that’s in the videos and use the left hand side of VS Code and Finder to copy your files.

Um… I lost the instruction at 4:02
I am using Window, but got a message like this. see snap shot.


You just need to move into the folders like this cd WebDeb, cd is the keyword to move into folders.

Be sure that the folder path is on the actual folder you are in the console (C:\Users\Tzion), you can also use dir keyword to show all the folders inside the one you are.

Hope it helps.

Carlos Z

It doesn’t give me the option to select my command prompt

1 Like

yea im having the same issue here

1 Like

HELLO MODERATORS! I am experiencing this same issue and no one has given it a solution. I can’t proceed with the course until I’m aware of what I’m doing wrong. Please help.

1 Like

Hey @Connorgeldmacher, @Green, hope you guys are ok.

Could you please describe a little bit more about your issue? Which OS are you using?

Here you can read more about how to use the VS terminal

Carlos Z

I was having the same issue as the person who posted the screenshot. To fix the issue I went to File Explorer > This PC > Local Disk (C:) > and then I right clicked and created a new folder and named it “WebDev”

Once I did that I was able to follow along with the instructor again. The video does not make that clear at all and seems to assume that the new student already has this folder created

1 Like

I am having a similar issue. These videos are great if you are running on windows. After spending hours trying to learn macOS terminal commands, we can use a video on how to run macOS terminal commands.

1 Like

The issue is that it was pre-assumed that basic command prompt (Windows) or terminal (Linux, MacOS) commands are common knowledge or at least they are very easy to research. This research pays off by the way, as without this small exercise, later exercises will become increasingly difficult.

Let me quote what was said in the video at 4:02.

“So create a dedicated folder for your project. For example, for me it’s almost always c:\webdev or e:\webdev or d:\webdev; and inside that, you can create a new folder with either md or mkdir”.

First of all, both Command Prompt (Windows), Git Bash (Windows), Terminal (Linux, MacOS) work. It is up to you which one you choose.

You don’t have to follow my keyboard commands. The instruction was about finding a folder you want to use. You can create a folder for yourself wherever you want to or use an existing folder. If you don’t know where to create your folder and you are on MacOS or Linux, then just use your home folder:

cd ~

Tilde is your home folder. Then follow the instructions with md or mkdir and forget about the WebDev folder.

If you have Windows, then you can execute the following sequence of commands (replace c with another letter in the first command in case you wanted to use another of your drives):

cd / 
mkdir WebDev 
cd WebDev

The first switches to your C drive, the second changes your current directory to the root folder in C:, the third creates a new WebDev directory, the fourth navigates you into the WebDev directory.

Problem solved.

Could I have some advice on" visual studio code", please? I’m trying to completely reset it, as if, as if I have never used it, because I tried using it it before and this appears to be causing problems.I keep getting error messages, for functions that are being taught, here in the Academy and which worked previously, when I was initially using it for the course.
*I’ve tried to uninstall and reinstall, and have deleted all previous files when using it before, but it still functions as if, it remembers my old files