Setting up your environment

When I tried executing the command “truffle init” from the Windows PowerShell (after npn install -g [email protected]) I received the following error: “…AppData\Roaming\npm\truffle.ps1 cannot be loaded because running scripts is disabled on this system.”

The resolution to this problem seems to be the following which is executed in PowerShell:
Set-ExecutionPolicy -Scope CurrentUser -ExecutionPolicy Unrestricted

1 Like

If you want solidity language syntax highlighting, auto-indent, etc. install the language-solidity package for atom:

Hey @mvernon, hope you are well.

That message could mean 2 things:

  • you are trying to run a command inside the “system32” folder, which is a protected windows folder.
  • you are trying to run a command without admin permission (mean you have to open powershell as administrator).

And yes, I also have the solidity languange package for my Atom, works perfectly :nerd_face:

If you have any more questions, please let us know so we can help you! :slight_smile:

Carlos Z.

Thanks - I was having the same problem. This works! - Was not sure weather to input [Yes] or Yes but Yes worked