Register for BTCPayServer


I am at the point in the course where I need to register for account for my BTCPayServer:

But there seems to be something I am completely missing here: Why do I have to go to to register for BTCPayServer account? Shouldn’t that be at some BTCPayServers own site?

Also: I get no email when I click “send verification email” here:


You have to register on Filips BTCPay server its a self hosted service.

I’m not sure why aren’t you getting the verification email. Can you login to the server?

Thanks for getting back.

OK - so it is the equivalent of me setting up my own BTCPayServer, and then using that to register right?

Not sure what you mean by can I login - I am in the settings menu here: - those settings are behind login - so yes?

Yes you can setup your own server if you want.

If you can login then you are all set, I don’t remember receiving an email either. :slight_smile:

1 Like

Thanks. Filip mentions that he has documentation for easily setting up your own BTCPayServer - can you provide that link maybe?

Also I get this error when running the command giving in the API pairing lecture ( - some setup missing? - I am on windows 10 in powershell prompt in the directory of the install:

BTCPAY_URL= BTCPAY_KEY={my private key} BTCPAY_PAIRCODE={my pair code} node -e “const btcpay=require(‘btcpay’); new btcpay.BTCPayClient(process.env.BTCPAY_URL, btcpay.crypto.load_keypair(Buffer.from(process.env.BTCPAY_KEY, ‘hex’))).pair_client(process.env.BTCPAY_PAIRCODE).then(console.log).catch(console.error)”

BTCPAY_URL= : The term ‘BTCPAY_URL=’ is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that
the path is correct and try again.
At line:1 char:2

  • BTCPAY_URL= BTCPAY_KEY=82cb8ff …
  •  + CategoryInfo          : ObjectNotFound: ( [], CommandNotFoundException
     + FullyQualifiedErrorId : CommandNotFoundException

I’m not sure if Filip has the documentation to setup your own BTCPay server and he probably didn’t update the instructions for a while now. You have several options how to deploy your own server and I would suggest you use their official docs, I know that Filips deployment uses Docker:

Did you use the instructions for Powershell? On Windows you must set ENV variables before executing the command to generate the key, can’t do it in one line:

Sorry Ales. Think I got a bit too eager - so I didn’t read it - it works now I have folowed the instructions on GitHub

Thanks again ;o)

But big sigh - it doesn’t work when I try and issue the “npm start” command - any idea why I get this error?:

npm start

[email protected] start C:\Users\frt\Ivan\Lightning\lightning-app-boilerplate
node ./bin/www

return this.x.fromRed();

TypeError: Cannot read property ‘fromRed’ of null
at Point.getX (C:\Users\frt\Ivan\Lightning\lightning-app-boilerplate\node_modules\elliptic\lib\elliptic\curve\short.js:415:17)
at Point._encode (C:\Users\frt\Ivan\Lightning\lightning-app-boilerplate\node_modules\elliptic\lib\elliptic\curve\base.js:295:16)
at Point.encode (C:\Users\frt\Ivan\Lightning\lightning-app-boilerplate\node_modules\elliptic\lib\elliptic\curve\base.js:304:28)
at Point.encodeCompressed (C:\Users\frt\Ivan\Lightning\lightning-app-boilerplate\node_modules\elliptic\lib\elliptic\curve\base.js:290:15)
at Function.get_sin_from_key (C:\Users\frt\Ivan\Lightning\lightning-app-boilerplate\node_modules\btcpay\dist\core\cryptography.js:16:47)
at new BTCPayClient (C:\Users\frt\Ivan\Lightning\lightning-app-boilerplate\node_modules\btcpay\dist\core\client.js:13:53)
at Object. (C:\Users\frt\Ivan\Lightning\lightning-app-boilerplate\routes\invoice.js:9:16)
at Module._compile (internal/modules/cjs/loader.js:1137:30)
at Object.Module._extensions…js (internal/modules/cjs/loader.js:1157:10)
at Module.load (internal/modules/cjs/loader.js:985:32)
at Function.Module._load (internal/modules/cjs/loader.js:878:14)
at Module.require (internal/modules/cjs/loader.js:1025:19)
at require (internal/modules/cjs/helpers.js:72:18)
at Object. (C:\Users\frt\Ivan\Lightning\lightning-app-boilerplate\app.js:9:21)
at Module._compile (internal/modules/cjs/loader.js:1137:30)
at Object.Module._extensions…js (internal/modules/cjs/loader.js:1157:10)
at Module.load (internal/modules/cjs/loader.js:985:32)
at Function.Module._load (internal/modules/cjs/loader.js:878:14)
at Module.require (internal/modules/cjs/loader.js:1025:19)
at require (internal/modules/cjs/helpers.js:72:18)
at Object. (C:\Users\frt\Ivan\Lightning\lightning-app-boilerplate\bin\www:7:11)
at Module._compile (internal/modules/cjs/loader.js:1137:30)
npm ERR! errno 1
npm ERR! [email protected] start: node ./bin/www
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the [email protected] start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\frt\AppData\Roaming\npm-cache_logs\2020-12-30T13_01_16_496Z-debug.log

What version of Node are you using? Have you tried with the LTS version?

v12.18.3 - LTS what is that?

Long term support version. I have tried using executing the project with the latest node version and seems to work fine. Did you reinstalled the packages after you audited them as you mentioned in the other topic?

No I didn’t - I have upgraded to latest release of Node now.

I then tried downloading github repository again (new location).

Then running npm install in that directory (still says 1 critical audit)

Then running npm start -

same error :O(

Did you enter the BtcPay keys in innvoice.js?

Hmm apparently not after the reinstall - did now and the server starts fine.

I think I am through the woods and can now follow the course.

Thanks for getting back - and so quick also during these christmas days - that has been a fantastic service beyound what I expected.

Hope this is the last you hear from me in a while (regarding problems at least)

Have a fantastic new years

;o) Frank

I’m glad you made it work! If you have any other questions don’t hesitate to ask. :slight_smile:

1 Like