New Ledger + MM integration

Hey Guys,

So I am really curious about why my transactions for staking are not going through. (and have opened a ticket with Ledger and MM, but not heard back yet). So the new update launches about 3 days ago:

This fix was supposed to repair the bridge having to be open in order to perform a tx, however while it fixed the need to open Ledger Live and the bridge, it doesn’t seem to be in full function mode, now this could be due to the browser I am using (Brave), but here is what I did and what is still not working.

These are all the things I did for the update:

added firmware and MetaMask upgrade

I ensured you have the most updated firmware and have updated MetaMask to 10.5.1

Metamask => Settings => Advanced => Preferred Ledger Connection Type == WebHID

Metamask => Account Options (three vertical dots to the right of account name) => Expand view

Connect your Ledger to computer and open the Ethereum app on it (doesn’t matter what network coin you’re doing, the Ethereum app needs to be open). If you don’t have Ethereum app, install it through Ledger Live. Ensure Blind Signing in that app is enabled.

Open up new tab and go do your staking. When the approval comes up the Continue button may be greyed out. If it is go the “full screen” MetaMask tab from #2. Look at Activity and you should see the pending transaction. Click on it and the Continue button should be visible now.

Continue and view transaction on your ledger.

Unfortunately I cannot approve transaction on the window that opens in expanded view, it is still grayed out.

1 Like

Hey @KMAB, hope you are great.

Your might wanna take a look into this tutorials :nerd_face:

Hope this helps.

Carlos Z