Lost my code in Remix (looks like they changed the UI)

I updated the Brave browser and now it looks like all my work in Remix is gone. I can’t even open new files. It seems like Remix done an upgrade to the UI.

Looks like this, and when I click “New file” nothing happens.

Skärmavbild 2021-03-29 kl. 14.46.24

Ey, I fixed it. I had to do “Migrate old filesystem to workspace”.


1 Like

Hi, so many times I saw that issue was around lately. besides Workspace feature I wanna share another way of working in remix.

We can study with the files which we host in our computers without any chance to lose them instead of caching in browsers. This also keeps the codes private.

To do:

  • Download remixd: npm i -g remixd
  • run: remixd -s /project_folder/ http://remix.ethereum.org
  • remix webpage, choose workspace: localhost

NodeJS required
/project_folder/ is the place that the files are gonna be saved. Regular path, nothing tricky. Maybe requires " "

1 Like

Thanks for the tip. Works as far as the connection to localhost. Remix can’t find the deamon running in the background. I’ve tried a few different variants.

>> remixd -s /Users/lars\ dobos/IvanOnTech/ --remix-ide https://remix.ethereum.org/#optimize=false&runs=200&version=soljson-v0.7.5+commit.eb77ed08.js&appVersion=0.8.0&evmVersion=null
[1] 54278
[2] 54279
[3] 54280
[4] 54281
[2]   Done                    runs=200
[3]   Done                    version=soljson-v0.7.5+commit.eb77ed08.js
[4]+  Done                    appVersion=0.8.0
>> [WARN] You may now only use IDE at https://remix.ethereum.org/#optimize=false to connect to that instance
[WARN] Any application that runs on your computer can potentially read from and write to all files in the directory.
[WARN] Symbolic links are not forwarded to Remix IDE

Mon Mar 29 2021 22:14:54 GMT+0200 (centraleuropeisk sommartid) Remixd is listening on

But I stil get:

###### Alert


Cannot connect to the remixd daemon. Please make sure you have the remixd running in the background.

Hi again,
sorry i missed your question.

  • Please try http instead of HTTPS at the remix url.
  • To make it guarantee, keep your path inside (") double quotes, 'cos you had to use an escape chararacter, i’m not sure but it might cause a syntax error.

Where is that?

(… adding random text because this stupid forum is configured to require a minimum of 20 characters)