Help! Having issues with EOS Studio

Hi Guys,

Hopefully this is the correct place for this post.

I’m trying to install EOS Studio on windows. When I try to install the Docker i get a mess age saying Installation Failed (screen shot attached) Docker Desktop Requires Windows 10 Pro Enterprise (15063+) or windows 10 home (19018+). I have updated windows 10 today before trying to install EOS.

So, trying to figure out that problem led me down the rabbit hole of installing Windows 10 SDK…now this wouldn’t install…I get to 43% then rolls everything back and says basically that I don’t have the privileges…it’s my laptop!! All the details in that error message or on the attached. I also have a log of the issue.

I have run MicrosoftProgram_Install_and_Uninstall.meta but that was useless!!

I have searched high and low for a fix but I couldn’t find anything helpful. It seems other have had this issue when trying to install WSDK but no fixes.

Can anyone help me fix this issue? Has anyone has this when trying to install the Docker?

Cheers guys.



Hello sir, could you please find out the version of your windows? the same issue from the windows SDK installer could be the same for the docker, Also, are you running those installers with Administrator permissions?

If you have any doubt, please let us know so we can help you! :slight_smile:

Carlos Z.

Hi Carlos,

It seems that I just have one issue after the other here. I finally got docker installed…so I open EOS Studio, open my project, when I clock on local - topright on EOS Studio I’m asked to install EOSIO, I click on EOSIO install, choose the latest version v.2.0.6, I click install, I’m then greeted by 'Docker Error please make sure docker daemon is running. I have tried everything…I’ve installed hyper-v, I have run diagnostics and unloaded them and asked for help on the docker forum…no one has yet said they have a solution…to be honest mate I’m on the verge of throwing the laptop out the window…the laptop is new a few months old, more than adequate spec etc.

Do you think it would make a difference if I upgraded from windows 10 home to windows pro? I have seen a few posts from others saying this solved their problem.

Any help you can give me would be great, I’ve watched so many videos and read so many posts on this I’m losing my mind!!



1 Like

I have also tried running to Docker command test hellow-world and got a similar error message as per the latest attachment. It seems that all things are point toward the docker daemon not being able to connect…

Finally got docker running with this command if anyone else has this issue - cd “C:\Program Files\Docker\Docker”./DockerCli.exe -SwitchDaemon

My issue now is I’m still getting the same error message when trying to install EOSIO - 'Docker Error, Please make sure docker daemon is running. I still get the same error message when running the command - run hello-world.

Why the hell is this so damn hard!!! :rofl:

Probably It’s not the laptop, it’s the windows version, has the installer said before, upgrading is not always the best choice since could left some old system files that will give you even more headache. You can try, but I cant promise it will fix the issue.

So the simple option is that you install a virtual machine on your computer, install a VM with linux and use it only for the course.
The complex option is to install completely a windows 10 more updated, which can be reaaaallly complex if you don’t know what you are doing.

If you have any doubt, please let us know so we can help you! :slight_smile:

Carlos Z.

Cheers Carlos. I’m currently installing Ubuntu on the laptop and will use that for the course.

Thanks for getting back to me.


1 Like

Did that work for you?
I gave up on the EOS course because I couldn’t get the software to work on my Linux.
I get a little bent that the videos typically the instructor says “If you’re on Linux you know what you’re doing.”
Uh. Not necessarily.

1 Like

Hey @petra, hope you are ok.

Let me know which error is being showed to you, maybe i can help.

If you have any more questions, please let us know so we can help you! :slight_smile:

Carlos Z.

1 Like

Thank you Cecil.
I’ll probably tag you in a couple of days.
I’m trying to figure out path errors on VSCode atm,
and I have someone helping with that.
It’s great that there is so much more support here lately.
It’s very appreciated.

1 Like

I’m having an issue also installing EOS studio. Getting a weird error that I haven’t seen anyone else talking about:

Any ideas why it doesn’t recognize git?

1 Like

You might have to install

Also keep in mind, the EOS course is very old, so you probably will face more issues on the way, for now there is no plan to update our EOS courses, they have made a lot of changes on their syntax and sdk, also EOS studio does not work for more than a year now, so expect more issues, and sorry for the bad experience

Carlos Z