Ganache: The hostname is not local address

Hello, I’m encountering weird issue with Ganache today.
I opened one of my workspace in Ganache GUI app, and I got the following error message:

The hostname is not local address; only use hostnames/IPs associated with this machine

Screen Shot 2021-05-21 at 10.27.19

What is also strange is that I only see one option: Interfaces. I usually have like 3 or 4 options:

Screen Shot 2021-05-21 at 10.31.26

My other workspaces are fine, and I have no issue creating new workspace. However, I have been working in this workspace for pretty long time, so I don’t want to restart it.
I searched online for help, but I couldn’t find any page regarding this issue.

Any idea?


the problem is that you cant just write whenever address you like, there are network rules to follow when setting an IP for a machine or device, is used for localhost, basically the device you are working, while the does not refer to any IP address device.

Also you can use the same for different workspace, the difference on them can be set on the port that they will use (example:

Hope this helps.

Carlos Z


By changing the port number, I think I was able to solve the issue.
Thank you!

1 Like

Hi guys,

young learner here. I got the same problem here, no host available anymore(…
So, i fixed this with open file explorer(windows), research “ganache” and delete all files and folder. Then, install ganache again. That’s worked for me.

1 Like

Close ganache -> go to %appdata% -> delete the ganache folder -> open ganache again .
This worked for me