EOS Tokens - Discussion

Welcome to the discussion thread about this lecture section. Here you can feel free to discuss the topic at hand and ask questions.

When I deploy eosio.token to my local, got this error message. Any idea of it?

You must have a eosio.token account in order to deploy a contract to eosio.token. Try that and let me know.

i cant deploy .

i cant deploy contract ,

I’m trying to create the token, but get an error about signatures:

transaction declares authority '{"actor":"eosio.token","permission":"active"}', but does not have signatures for it.
  "code": 401,
  "message": "UnAuthorized",
  "error": {
    "code": 3090003,
    "name": "unsatisfied_authorization",
    "what": "Provided keys, permissions, and delays do not satisfy declared authorizations",
    "details": [
        "message": "transaction declares authority '{\"actor\":\"eosio.token\",\"permission\":\"active\"}', but does not have signatures for it.",
        "file": "authorization_manager.cpp",
        "line_number": 592,
        "method": "get_required_keys"

Something wrong with the eosio.token account?

Did you compile it first?

This seem to be an issue with eos studio. The online IDE wallet doesn’t seem to have the underlying keys for the eosio.token account. There is already some threads about this in the eosio forum. If you want to continue and not wait for a solution from them. You can run eosstudio locally, then you have full control of the keys.

Eosstudio is now available for windows as well :+1:

1 Like

That worked, but EosStudio stil has some issues. Sometimes the complete window gets blank.

I think I’ll start another course and hope still will be fixed after.

I’m sorry to see that. I will let the dev team know over at EOS studios and let you know if we find a solution.

I’ve been stuck on Creating Token tutorial

Whenever i try making use of the create method/Action

I get this weird Error.

Really wish I could get a quick reply from anybody.

This is a bug in the online version of eos studio. I notified the devs but they have done nothing about it so far. Can you try the local version?

1 Like

Tried the Local version, couldn’t get to downltoad System Contracts .

Once I click on the Install button beside it, it runs some git command and then the dialog box closes, cloned project was successfully downloaded, yet, it’s never checked green.

I tried importing the eosio.token from the file option, gets an error stating i haven’t downloaded the respo.

Ok, I’m sorry to hear that it’s not working. This software is new and unfortunately it seems to be buggy for some. Another option you have is to continue with the web version, but you have to deploy the eosio.token contract code yourself and not use the built-in one.

No problems.
Thanks for your time.


1 Like

I have a error msg when building eosio.token

I am getting the same error as @cherrybluemoon when I try to build the eosio.token contract.

I am using the EOS Studio Web version on Windows. First, under Account, I switched to eosio.token (because it was already available in the menu list, along with eosio and my account). Then, I created a new project called eosio.token. Then I went to Project Settings, verified the settings, and built the contract, but I got this error message.

Any thought?

Moving on towards EOS 2.0.1 anyway :wink:

@cherrybluemoon check this one too please!

Hello sir(s), could you please show me an screenshot of the code?
Also if you are using the EOStudio, which compiler version are you using? (EOSIO.CDT)

On EOStudio website, bottom left corner, you can see the CDT version.

image .

If you have any doubt, please let us know so we can help you! :slight_smile:

Carlos Z.

Yes sure, here is the code of eosio.token.cpp:

This is the default code proposed by EOS Studio when I created the eosio.token contract.

The CDT version I used is v1.6.2 as Filip instructed in a previous video. I tried with v1.6.3 as well but I got the same error.