EOS programming 201, installing Nodeos

Hi all,
I’m running the latest version of ubuntu on windows using WSL, which I’ve setup correctly because it works fine when I use WSL for EOS programming 101.
I’ve also installed the latest ubuntu Debian Package Install (ubuntu 20.0.x) and CDT (from binary) which I obtain directly from EOS’s github.
However, after setting it up, I don’t think it installs Nodeos at all. Because when I tried the Nodeos start command

nodeos -e -p eosio –plugin eosio::producer_plugin –plugin eosio::chain_api_plugin –plugin eosio::http_plugin –plugin eosio::history_plugin –plugin eosio::history_api_plugin –access-control-allow-origin=’*’ –contracts-console –http-validate-host=false >> nodeos.log 2>&1 &

also when I run the start nodeos command above I got the following respond, which I assume that something is working?

then I tried to run the nodeos.log command as describe by fillip in the video “Start Nodeos” by using the following:

tail -f nodeos.logs

I got a command back saying, nodeos is not an existing command. I’ve read through the EOS github page and did a quick google search, and I don’t seems to find anything describing how to install nodeos correctly.

I’ve already tried restarting wsl, as well as, restarting my computer. neither solved the problem.

so anyone have any ideas, what’s going on? do I need to install more packages? or did I need to use another command to get nodeos started?

To anyone that uses Window’s WSL to try to do this course. I’ve been trying and trying to get nodeos running (time of writing this is July 2023), it doesn’t seems to like working with WSL or WSL2 at all.
I’ve tried to run Ubuntu 20.4, Ubuntu 18.6 and Ubuntu 16.4 to install EOS environment and get nodeos to work.
As of July 2023, the EOS environment simply doesn’t work and cannot be installed into WSL version of Ubuntu 20.4, as a matter of fact I did some diggings. I think a lot of the libraries that needed to install the EOS environment, is obsoleted and just doesn’t support Ubuntu 20.4 at all.

I manage to the Environment installed and do something with it (e.g. work with cleos, creating keypairs and account) after getting WSL version of Ubuntu 18.4, but no matter how hard I try and look, I can’t get nodeos to run, and to further extend nodeos.log doesn’t run either because of that.

I thought I can work around it or solve the issue by installing Docker, but Docker doesn’t like to work with WSL either.

I’ll continue taking this course and learn the major concepts and programming of this. But I think at this stage, its not worth the time and effort, working with EOS if you’re using Window like.

After I completed the course, and have the energy to do so, I might install an actual Linux OS on my machine and redo the course. Or buy a Apple/ Linux machine. But at this point of time I think its just a great hassle and confusion to get it to work. And I kinda of understand why Solidity and Rust is so much more popular and easier to use.