Creating our Token Discussion

hi i have a problem on compiling please help me

Hello @josejalapeno,

You are using what the version of:

  • Truffle
  • npm
  • Node.js

I used v14.18.0, may work for you. Try reinstalling Node.js (then try also initializing the directory again with npm init and install needed dependencies again)

Hope this is helpful to you
With kind regards

hello @alp257

my node verson is16.13.1

my truffle i install the 5.0.1

my npm is 7.24.1

what should i do step by step to downgrade my node?

1 Like

What you can try first is running ‘npm cache clean --force’ (just to make sure no data corruption was there even if it only happens rarely) then see if the problem still exists.

Next, instead of ‘downgrading’, I suggest uninstalling Node.js and npm then installing them again afterwards.

With kind regards

1 Like

if you want to switch node i sugges using node version manager this way you can download an duse any version of node you want and switch between them. heres their github for installation read the docs

I did do a little reading on that error too few ansers on SO said its most likley compatability with node and trufle. but yur version of node is fine v14 is what i use. i suggest removing truffle completely and starting again maybe something happened during instialltion thats causing this

1 Like

Seems like you’ve suddenly been flooded by advice!! :sweat_smile:

Here’s a link to an FAQ which might also be helpful. Hopefully, something will do the trick :smiley:

1 Like

@josejalapeno In case you haven’t seen this …

1 Like

yes i also install the nvm yesterday and did some youtube around it, i can swap to the old node, but then npm doesnt work, which means i cant install truffle without npm, without truffle i cannot develop and compile the codes.

If you can’t get npm working when using the Node Version Manager then I would suggest uninstalling everything again and re-installing Node.js from the link in these instructions I posted yesterday…

It will take you to all of the downloads for previous versions of Node.js, and I’m pretty sure that these files will install both Node.js and npm together. That’s correct isn’t it @mcgrane5 @thecil @alp257 ?

The instructions in this FAQ will also explain how to uninstall correctly.

1 Like

It could also be that the installation went wrong, you could try to uninstall the version from nvm, then install it again, keep in mind that you should do all of this as administrator.

Let us know how it goes for you, i recently install v16 and was able to npm install truffle without any issue.

Carlos Z


@Jon sorry for late reply. But yeah i strange the way nvm didnt work. I would suggest following @thecil 's advice and unistalling node and trying again. i also agree i dont think it should be the node version because im running 14. something and its fine. it could be the truffle install didnt work correctly. so try redo everything again from scratch.

Simply deleteing node or unistalling it inst enough if your gonna do it you should uninstall it and delete any roaming data in app/roamingdata on your machine. could look up a tutorial on how to do this. let us know how you get on we will get this fixed for you


@josejalapeno In case you haven’t seen this latest advice for you …

1 Like

Hi I’m having troubles downloading the linter package.
Installing “[email protected]” failed.Hide output…

npm ERR! code E500
npm ERR! 500 Internal Server Error - GET

I don’t understand why I keep getting this error for any package I try to download and would appreciate help.

1 Like


Hello, probably you have to change something with Atom’s configuration, tweak something related to the linter package (the package may be already obsolete). Not familiar with Atom’s configuration, sorry, since commonly one use VS Code for Solidity development instead because of its more robust environment.

Hope the information is helpful.
With kind regards


There is an error on that application, just check the URL, you will receive an app error "message": "Application error".

I suggest to start using VS Code for all our programming courses, atom is nice but it does not have that many extensions or features like VS Code, also most of our courses are using VS Code.

Carlos Z


Thank you. I decided to move over to vscode

issue when deploying Token

When migrating the contract i have the following error;

type or paste code here
truffle(develop)> migrate
Could not connect to your Ethereum client. Please check that your Ethereum client:
    - is running
    - is accepting RPC connections (i.e., "--rpc" option is used in geth)
    - is accessible over the network
    - is properly configured in your Truffle configuration file (truffle.js)

i have installed ganache
i have installed testrpc

but i still have this error of connection

this is my truffle-config.js file:

  networks: {
    // Useful for testing. The `development` name is special - truffle uses it by default
    // if it's defined here and no other network is specified at the command line.
    // You should run a client (like ganache-cli, geth or parity) in a separate terminal
    // tab if you use this network and you must also set the `host`, `port` and `network_id`
    // options below to some value.
      development: {
         host: "",     // Localhost (default: none)
         port: 8545,            // Standard Ethereum port (default: none)
        network_id: "*",       // Any network (default: none)

Hello @patgeek

There are two approaches to proceed:

  1. in the course, Ganache was not used but rather a testnet (Ropsten), try configuring your truffle to use Ropsten
  2. if you really want to use Ganache, you have to setup your web3 wallet (i.e. Metamask) by adding a network to a localhost to communicate with the local dev blockchain spun by Ganache.

Hope the information is helpful to you
With kind regards


i have configured truffle to use Ropsten:

  ropsten: {
      provider: () => new HDWalletProvider(mnemonic, `${projectId}`),

      network_id: 3,       // Ropsten's id
      //gas: 5500000,        // Ropsten has a lower block limit than mainnet
      gas: 0000005,        // Ropsten has a lower block limit than mainnet
     confirmations: 2,    // # of confs to wait between deployments. (default: 0)
    timeoutBlocks: 200,  // # of blocks before a deployment times out  (minimum/default: 50)
    skipDryRun: true     // Skip dry run before migrations? (default: false for public nets )

when i try to migrate my project to ropsten i have an out of “Ran out of GAs” error:

type or paste"Migrations" ran out of gas (using a value you set in your network config or deployment parameters.)
   * Block limit:  8000000
   * Gas sent:     5500000 code here

what can i do to solve this ran out of gas issue?

1 Like

no remove the gas param you have in your tufflecConfig.js file, re u tryinh to deply to ropstent yes. its jst trial and eeror might take afew times but get rid of thr gas param in yout truffle config

1 Like