Cannot install Npx

Hi @zsolt-nagy

I would like to do the course but when I execute command npx create-react-app coin-exchange I get the following error:


for now I have tried on Powershell, restarting windos and many people did some yarn upgrade regarding to this issue but no avail from me.

I will try to google it for now, but could you please help?

Thank you.


Restarting did not work, but of course today it was installed succesfully :slight_smile: (azért köszi).

Nice to know that you made it!
You could also use CMD (windows command prompt) instead of PowerShell.

but apparently the issue that you had was likely to be a internet issue than your powershell or npm, i mean you get a 404 Not found, which could be that your internet just went down for a sec.

Carlos Z

@zsolt-nagy @thecil
Well I was able to install the things but I got this now, this is when I am running npm start:


Seems like some kind of an Npm issue but don’t know how to solve this one.

I have tried some google things, no avail, maybe waiting 1 day will solve the issue again…

UPDATE: I have found the issue was because I have used an earlier version of npm ( because of the algorithmic trading course. I switched to latest and all good to go.

1 Like

Hey @Riki, hope you are well.

Sorry for the delay to help you with this, so changing the node version solve the issue right? you were using v12 for the trading algo course and you switch to which version now? just curious :nerd_face:

Glad to know you solve it!

Carlos Z