Building the game in Unity - Discussion

Feel free to ask questions or discuss the content in this section below.


Just getting to the “Acceptable Jumping” lecture for the new Unity course, awesome by the way!

However, there seems to be no audio. The lectures before and after are fine.


P.S. It seems “Collecting Coins” also has no audio.

Teachable has some bugs with it atm, try refreshing the page, the audio is there :slight_smile:

I have already finished the course because the videos are easy enough to follow and understand. It is strange though, as I go back to see them today, they are still the same. Seemingly only those two… strange.

Anyway. Thanks. Great course.

Hi Ivan, I just started the course today. I was able to download Unity Hub and follow through all the steps. However, when i tried creating a new project it says invalid license. Is there a way to solve this problem? I have a macbook pro.


solved! I was able to solve this when I tried activating new license with a new gmail account.

Could it be that the sound v/o for the “Acceptable Jumping” in the Unity 101 is missing/buggy?

Experiencing the same issue w/ “Collecting Coins” - a bit of a pitty when the classes are building up on one another. Do you have a bounty on the bugs? How about a free shoutout on the show to - the tech community around Frankfurt? :wink:

Hi Ivan

I’m having the sound problem on the same 2 lectures. Have reloaded and rebooted. Nothing helps. I’m running a Chrome browser, Version 75.0.3770.100 (Official Build) (64-bit). I strongly suspect there is an issue with the audio on these 2 lectures.

Thanks - TY.

Hey sorry for that! @TonyY @Make_Europe

We had issues with the sound on 2 lectures - “Acceptable Jumping” and “Collecting Coins”.
Should be fixed now, please let us know if you find more issues!

1 Like

Thanks Ivan - had the same audio issues earlier but it’s all fixed now. Fun course - I adapted it to do the same thing using Godot instead, funnily enough Enjin are Platinum Sponsors of that Game Engine, so it will be interesting to see if I can adapt what I learn from the next course into that. Just one very minor thing - One of the courses has a spelling mistake - it is titled: “Spawning Conis” on the Left hand side nav bar and the title where it should be “Spawning Coins”

Looking forward to the next one - the blockchain meat of the course :smiley: - Thanks

1 Like

Hi all, on the Unity training section - controlling the character par, I select the jelly, and circle collider 2d in its attribute then try and search for PLAYER CONTROLLER in the add components search part and its not there… As in your video…

Just wondering in mine wheres it gone or how to get it back…!!! my friend any suggestions…
Unity Version: 2019.1.10f1

Hi Ivan, thank you for the great content again! This academy is really enriching. I have a question regarding Unity (VR) and Enjin. Is it possible to connect Enjin not only for video games but also to the Virtual Reality (VR) component of Unity?

I had the same license issue with Unity. And then when I moved my laptop to a different network I had it all over again. It is quite solvable…repeatedly.

However Unity does not seem fit the decentralized ethos of this Academy. I know: there is a permissioned blockchain course here too. Even so: tying crypto to a commercial runtime engine like Unity feels existentially awkward.

May I request a course using an open-source game engine like Godot instead? Godot is not as polished as Unity, but may be more uniform across platforms. For example Unity Hub on Linux does not seem to exist. Unity on Linux is…probably no better than Godot on Linux.
That isn’t a high bar. Godot still seems functional enough-- so far as this course is concerned.

1 Like

Hi there, I started the Unity Blockchain Game Development course today. I got some issues in lesson 10, I copied the entire script in Visual Studio Code however the movement of Jelly doesn’t seem to work. The option to enter the speed value won’t appear. I hope someone could help me out.
Thanks in advance.

1 Like

Try tagging the instructor if you’re still having problems?

Hi, lessismore.
I’m sorry for the late reply, did you find any solution to your issue yet?

1 Like

Hey I cant get my speed function when I add the component Player Controller to my Jelly.

Screenshot 2020-05-24 at 15.17.13

using System.Collections;
using System.Collections.Generic;
using UnityEngine;

public class PlayerController : MonoBehaviour

    public float speed;
    private Rigidbody2D rb;
    private float moveInput;

    // Start is called before the first frame update
    void Start()
        rb = GetComponent<Rigidbody2D>();

    void FixedUpdate()
        moveInput = Input.GetAxis("Horizontal");
        rb.velocity =  new Vector2(moveInput*speed, rb.velocity.y);

    // Update is called once per frame
    void Update()


Anyone can see what I do wrong?

1 Like

Hi, Jacob.
Good to see you again, I will look at my code tomorrow and hook you up with an answer. In the mean time, just tripplecheck your code with Ivan’s, I’m sure it’s just a small error in your code.

If you don’t hear back from he, don’t be afraid to tag me and I’ll get the notification.:wink: You know how it is some times.:hugs:



Do you know if ivan have a gifthub where the code is uploaded? Like Filip does? @ivga80 and thanks for helping!

1 Like