[Windows Installation] Git VsCode NVM Nodes Ganache Truffle

there is only one line inside that file


You need to select
-> provableAPI_0.5.sol <-

And replace the name of the file in your contract

line 16

import "./provableAPI_0.4.25_simplified.sol";

replace it with

import "./provableAPI_0.5.sol";
1 Like

Yes. I did changed to provableAPI_0.5.sol; and change all “pragma …” definitions in all .sol files.
The same error:

truffle migrate --network ropsten --reset
Error parsing D:@TUNG 2020\IVANONTECH\SOLIDITY 201\coinFlip4\contracts\provableAPI_0.5.sol: ParsedContract.sol:32:137: ParserError: Expected ‘,’ but got identifier
/* INCOMPATIBLE SOLC: import the following instead: “github.com/oraclize/ethereum-api/oraclizeAPI_0.4.sol” */ function f(bytes calldata x) external;
Compilation failed. See above.

latest commit

Hi @tungtien

I answered you question here

You are still not using the correct version or the provable API


You are still not using the correct version or the provable API

That is the original provableAPI_0.5.sol file; I did not changed anything; The code you saw is this (I think that is just comment?) - but any way, I did not changed the content of this file:

pragma solidity >= 0.5.0 < 0.6.0; // Incompatible compiler version - please select a compiler within the stated pragma range, or use a different version of the provableAPI!

// Dummy contract only used to emit to end-user they are using wrong solc
contract solcChecker {
/* INCOMPATIBLE SOLC: import the following instead: "github.com/oraclize/ethereum-api/oraclizeAPI_0.4.sol" */ function f(bytes calldata x) external;

Hello, anyone has problem with truffle crashing? It’s better with node v9 but it still crashes sometimes

How frequently is it crashing?
If it really disturbs your development trying uninstalling and re-installing it. :slight_smile:

1 Like

Is it better to install node with msi or npm in vscode?

I suggest to go for npm
npm has far more libraries.

1 Like

Hello the command

Set-ItemProperty -Path HKLM:\Software\Policies\Microsoft\Windows\PowerShell -Name ExecutionPolicy -Value ByPass

Returns this error
Set-ItemProperty : Cannot find path 'HKLM:\Software\Policies\Microsoft\Windows\PowerShell' because it does not exist.


Can you elaborate your question a bit more? I am not sure what are you trying to do here?

If this helps you sort your issue: https://social.technet.microsoft.com/Forums/en-US/3ef5e0d7-0a45-4e18-96df-3e6bad879004/setitemproperty-example-code-doesnt-work?forum=winserverpowershell

Set-ItemProperty : Creates or changes the value of the property of an item. source: https://docs.microsoft.com/en-us/powershell/module/microsoft.powershell.management/set-itemproperty?view=powershell-7

1 Like



I’ve tried to follow the guide but at some point I got errors and so now I’m trying to do all over again.

In the first step after Set-ExecutionPolicy AllSigned I don’t get any error but anyway on Get-ExecutionPolicy -list i don’t get the machinepolicy allsigned:

 Scope ExecutionPolicy
        ----- ---------------
MachinePolicy       Undefined
   UserPolicy       Undefined
      Process       Undefined
  CurrentUser       AllSigned
 LocalMachine       AllSigned

if I try to do Set-ItemProperty -Path HKLM:\Software\Policies\Microsoft\Windows\PowerShell -Name ExecutionPolicy -Value ByPass

i get an error:

PS C:\WINDOWS\system32> Set-ItemProperty -Path HKLM:\Software\Policies\Microsoft\Windows\PowerShell -Name ExecutionPolicy -Value ByPass
Set-ItemProperty : Impossibile trovare il percorso 'HKLM:\Software\Policies\Microsoft\Windows\PowerShell' perché non
In riga:1 car:1
+ Set-ItemProperty -Path HKLM:\Software\Policies\Microsoft\Windows\Powe ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : ObjectNotFound: (HKLM:\Software\...dows\PowerShell:String) [Set-ItemProperty], ItemNotFo
    + FullyQualifiedErrorId : PathNotFound,Microsoft.PowerShell.Commands.SetItemPropertyCommand

I never used power shell before and I have no clue what to do (I didn’t get also how to change the language only in power shell).

How can I proceed? Thanks