Problem creating coin-exchange react app

create-react-app coin-exchange

Creates app with 1 error towards end
“Git commit not created Error: Command failed: git commit -m “Initialize project using Create React App””
at checkExecSyncError (child_process.js:630:11)
at execSync (child_process.js:666:15)
at tryGitCommit (C:\dev\react\coin-exchange\node_modules\react-scripts\scripts\init.js:62:5)

Happy hacking!

user@t5610 MINGW64 /c/dev/react
$ cd coin-exchange/

user@t5610 MINGW64 /c/dev/react/coin-exchange
$ npm start

[email protected] start C:\dev\react\coin-exchange
react-scripts start

The system cannot find the path specified.
npm ERR! errno 1
npm ERR! [email protected] start: react-scripts start

Log file says

info it worked if it ends with ok
1 verbose cli [
1 verbose cli ‘C:\Program Files\nodejs\node.exe’,
1 verbose cli ‘C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js’,
1 verbose cli ‘start’
1 verbose cli ]
2 info using [email protected]
3 info using [email protected]
4 verbose run-script [ ‘prestart’, ‘start’, ‘poststart’ ]
5 info lifecycle [email protected]~prestart: [email protected]
6 info lifecycle [email protected]~start: [email protected]
7 verbose lifecycle [email protected]~start: unsafe-perm in lifecycle true
8 verbose lifecycle [email protected]~start: PATH: C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bin;C:\dev\react\coin-exchange\node_modules.bin;C:\Program Files\Git\mingw64\bin;C:\Program Files\Git\usr\bin;C:\Users\user\bin;C:\Python38\Scripts;C:\Python38;C:\Program Files\Java\jdk-14.0.2\bin;C:\Program Files\graalvm-ce-java11-20.1.0\bin;C:\Program Files\AdoptOpenJDK\jdk-\bin;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0;C:\Windows\System32\OpenSSH;C:\Users\user\AppData\Local\Microsoft\WindowsApps;C:\Program Files (x86)\Windows Kits\10\Windows Performance Toolkit;C:\Program Files\dotnet;C:\Program Files\PuTTY;C:\Program Files\nodejs;C:\ProgramData\chocolatey\bin;C:\dev\apache-maven-3.6.3-bin\bin;C:\Program Files\Git\cmd;C:\Program Files\Docker\Docker\resources\bin;C:\ProgramData\DockerDesktop\version-bin;C:\Users\user\AppData\Local\Microsoft\WindowsApps;C:\Users\user.dotnet\tools;C:\Users\user\AppData\Local\Programs\Microsoft VS Code\bin;C:\Users\user\AppData\Roaming\npm
9 verbose lifecycle [email protected]~start: CWD: C:\dev\react\coin-exchange
10 silly lifecycle [email protected]~start: Args: [ ‘/d /s /c’, ‘react-scripts start’ ]
11 silly lifecycle [email protected]~start: Returned: code: 1 signal: null
12 info lifecycle [email protected]~start: Failed to exec start script
13 verbose stack Error: [email protected] start: react-scripts start
13 verbose stack Exit status 1
13 verbose stack at EventEmitter. (C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\index.js:332:16)
13 verbose stack at EventEmitter.emit (events.js:315:20)
13 verbose stack at ChildProcess. (C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\lib\spawn.js:55:14)
13 verbose stack at ChildProcess.emit (events.js:315:20)
13 verbose stack at maybeClose (internal/child_process.js:1021:16)
13 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:286:5)
14 verbose pkgid [email protected]
15 verbose cwd C:\dev\react\coin-exchange
16 verbose Windows_NT 10.0.19041
17 verbose argv “C:\Program Files\nodejs\node.exe” “C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js” “start”
18 verbose node v12.18.2
19 verbose npm v6.14.5
20 error code ELIFECYCLE

Can’t find anything on google - any ideas ?

Windows 8.1 npm recently installed

After googling i tried " node_modules/.bin/react-scripts start" and eventually got
“Starting the development server…”

“Compiled successfully!”

and my browser popped up on http://localhost:3000/

So success ?

You need to have node/npm installed on your computer. Then type npm start from the folder, where your package.json is. See the animation here in the document:

Actually if you check issues on GitHub you’ll see that this is an ongoing frustration.
My npm server was working yesterday, and today it is not.

I’ve gone through countless permutations of deleting the suggested modules and uninstalling and reinstalling various tools, and frankly I’m done.

I’ll be using the Python3 server until I feel like completely uninstalling and reinstalling all of absolutely everything nodejs and npm that I have on my computer (maybe never). Until then hopefully the create-react-app can catch up.

This unresponsiveness to the actual issue is exactly what I’ve run into in every course I’ve not been able to complete on the Academy.

It’s not your fault the updates killed the fun, but it’s not our fault either, and the GitHub page is basically a pile of this open issue.

For $1200 a year I expect some responsiveness to the actual problems.
For example, if I knew which node and which npm to downgrade to, that would help.
Once I have to go into files and delete modules and change json files and all of that to get the npm server to work, what’s the point? It was working. Now it is not.

If we have to solve these issues ourselves there are Udemy courses for $10 a pop and countless free tutorials on YouTube.

1 Like

Hey @petra, hope you are well.

Sorry for the inconvenience, sadly this is part of the computer space, we record videos with an specific version of a program which works good by the time, then they update them and we start having issues with our courses, sadly is too much time and almost impossible to re-record videos every time a new update comes in.

But we have design a quick guide to downgrade NodeJS to a version that should be fully compatible with all our courses, and is not only our courses, most of the developers suffer the same when a new version of the software is released (nodejs, npm or even solidity truffle versions).

Here is our guide: FAQ - How to downgrade Node.Js

Remember that if you still have some issues with the Academy, you can write to our support team to ask for help at [email protected]

If you have any more questions, please let us know so we can help you! :slight_smile:

Carlos Z.

I’ve got it solved.
I’m just saying that for the premium fees charged there could be better support.
I can show you issues with npm start going back YEARS that are not just “You have to have npm/node installed on your computer.”
For example, if it’s installed globally you need to uninstall and reinstall locally, then make sure you don’t have a node_modules folder in your home directory, and a myriad of other things, that for $1200 a year the instructor could at least mention.

It would also be helpful if system specific information were separated into its own videos.
It’s extremely frustrating to have to watch or figure out how to parse through without missing important side details, a complete Windows installation of a terminal.

There is never that kind of Linux support.
The instructors here actually say “If you’re using Linux you have it figured out” or “You know what you’re doing. You don’t need any help”, which I finally figured out means “We don’t use Linux so we don’t know and we don’t care.”

Or the very very very simple “Are you in the right folder?”
Because npm start will fail if you aren’t in the right folder, unlike the Python http server, which will spin up in your browser window from absolutely anywhere.

And since most of us start with Python that is obviously going to be the expectation.

Not to come down so hard, but damn.

No-one is expecting a fresh video with each update of each package, but responsive technical support would be appreciated.

There are basic issues people are asking about that are hanging for MONTHS.

I’m also having a similar problem, doing the react course.
Trying to install coin exchange but its not working, what I should do?

The screenshot shows an html file with links to React, React-DOM, and Babel. This is sufficient for you to start writing React code without create-react-app on its own.

The bottom terminal shows that you wanted to create a new project. The npx command worked, therefore there are no problems with your installation. However, I suspect you mixed two separate approaches in the same folder, therefore, I suggest moving to a different empty folder, and trying the npx command there.

1 Like

I thought about this solution already, but didn’t work, tried it again after your recommendation but unfortunately same result.

I’m thinking to uninstall everything and reinstall again, it may resolve the problem?

It works now, thanks